FluxTime Studio

Can you see a crazy robot to the left?

YesOK - your system is ready for FluxTime.

If you cannot start FluxTime, your browser or pop-up blocker might prevent FluxTime from opening a new window. If no window opens after you press the Start button, please configure your browser or pop-up blocker to allow FluxTime to open new windows.
NoPlease update your Java installation by clicking the Java button below.

System requirements

- Internet access
- A web browser supporting Java 1.4 or later

  GetJava Download Button       Java Powered


Web browsers: Internet Explorer 5.0 or later
Netscape 4.0 or later
Safari 1.0 or later
Operating systems: Windows XP, 2000, NT4, ME, 98, 95
Linux kernel v 2.2.12, glibc v2.1.2-11 or later
Mac OS/X 10.2 or later
Hardware: Intel Pentium processor or better
64 MB system memory or more
SVGA (800 x 600) resolution or higher

Testing your system...


It seems you have disabled JavaScript in your browser. Please enable JavaScript and re-load this page to complete the system check.

You cannot run FluxTime Studio without JavaScript!